SAS® Enterprise Guide® 1: Querying and Reporting

How-To Demonstrations

For SAS 8 and SAS® 9
# Table of Contents

| Lesson 1 | Getting Started | 1-1 |
| Lesson 2 | Working with Data in a Project | 2-1 |
| Lesson 3 | Working with Tasks | 3-1 |
| Lesson 4 | Creating Simple Queries | 4-1 |
| Lesson 5 | Creating Summarized Output | 5-1 |
| Lesson 6 | Using Prompts in Tasks and Queries | 6-1 |
| Lesson 7 | Customizing and Organizing Project Results | 7-1 |
Lesson 1  Getting Started
In this demonstration, you create a new project and then have a look around the workspace.

1. Open SAS Enterprise Guide.
2. When you start SAS Enterprise Guide, the Welcome to SAS Enterprise Guide dialog box opens automatically to enable you to create a new project or open an existing project. Any projects listed under the Open a project heading have a .egp file extension.
3. Select New Project. You can create a new project by selecting File ⇒ New ⇒ Project. You can select File ⇒ Open ⇒ Project to open an existing project.
4. SAS Enterprise Guide displays three main windows by default: the Project Tree, the Process Flow, and the Server List. The area where the Server List is displayed is also known as the Resources pane. You can select any of the four displayed icons to view the Task List, SAS Folders, Server List, or Prompt Manager.
5. By default, the Project Tree and the Server List are docked on the left side. You can change where windows are docked or you can auto-hide windows. Auto-hide hides the window, but displays the window name on the border of the SAS Enterprise Guide window. Place the cursor over the window name to make the window visible.
6. The Project Tree, Process Flow, and other helpful windows can be opened from the View menu.
7. Maximize the workspace.
8. To reset all windows to their original positions, select Tools ⇒ Options from the menu bar. Click Restore Window Layout, and then click OK.
   Select File ⇒ Save Project As. Navigate to a location where you want to save the project. Name the project Demo and click OK.
Lesson 2  Working with Data in a Project
In this demonstration, you add the Customers data set to your project. Then you view the data and the data properties.

In the Demo project, we're going to add a data set.

1. Open the Demo project. If you did not create a project in an earlier demo, start a new project.
2. Insert an existing SAS data set by selecting File ⇒ Open ⇒ Data, or click the Open tool.
3. To navigate to data stored on your personal computer, select Local Computer.
4. Navigate to the location where you stored the practice data for this course and double-click Customers to add the SAS data set to the project. A shortcut to the Customers data set is added to the Project Tree and the Process Flow.
5. By default, a snapshot of a few rows of the data appears in the Data Grid. View the data. Can you tell what type each variable is by the icon next to the column name?
   Open the Properties window for the data set and view the properties. Close the Properties window.
In this demonstration, you add a Microsoft Excel spreadsheet to the Demo project. Orion Star has a Microsoft Excel spreadsheet named products.xlsx that contains a list of products offered by the company. When you add the file to the project, the Import Data wizard opens so that you can create a SAS data set.

1. Open the Demo project if you saved it. If not, open a new project.
2. Click the Open tool and navigate to the location where you stored the practice data files. Add the Microsoft Excel workbook named products.xlsx. Note: If you do not have Microsoft Office 2007 installed on your machine, you can also use the products.xls file.
3. The Import Data wizard automatically opens. Verify that products.xlsx is the source data file and that the output SAS data set is products. Library indicates the default location defined by SAS to write the output SAS data set. Possible libraries include EGTASK, Sasuser, or Work. Click Next.
4. In step 2, verify that the ProductList worksheet is highlighted and that the First row of range contains field names check box is selected. Click Next.
5. In step 3, verify the default field attributes and click Next.
6. In step 4, accept the default setting for Advanced Options (nothing checked) and select Finish to complete the import process.
7. A new SAS data set is created and added to the project. You can rename the Import Data task to emphasize the name of the SAS table created in the import process. Right-click on the Import Data icon in the Project Tree or Process Flow and select Rename. Type Import Products. Verify the results and save the project.
In this demonstration, you add the fixed-width Orders.txt file into the project and import it as a SAS data set named Orders.

1. In the Demo project, select File ➔ Open ➔ Data. 
2. Navigate to the location of the course data and double-click orders.txt. The file is added to the project, but because it is not a structured data set, it cannot be used for reporting or querying.
3. Right-click orders.txt in the Project Tree or Process Flow and select Import Data.
4. In step 1 of the Import Data wizard, verify that the output data set is named orders. The library can be Sasuser, Work, or EGTASK, depending on your environment. Click Next.
5. In step 2, select Fixed columns. Select the File contains field names on record number check box and verify that the value is 1. Click on the start of each field to define the column breaks and click Next.
6. In step 3, modify the properties of the columns as described below:
   1. Exclude the Employee_ID column by clearing the Inc check box.
   2. Format Discount with a percent sign by clicking in the Output Format box and selecting the ellipsis button. In the Numeric format category, scroll to select the PERCENTw.d format. Change the overall width to 5 and click OK.
   3. Format Profit as a currency value by changing the drop-down list in the Type column to Currency. Click Next.
7. In step 4, do not make any changes. Click Finish to create the imported SAS data set. The Import Data task and orders data set are added to the project.
8. View the data set.
Save the Demo project by selecting the Save tool on the menu bar.
In this demonstration, you define a project library and add a table to the project via the library definition.  

**Note:** Because of configuration variations, only minimal steps are given here. If you do not have write access to a directory on the server, you might not be able to do this demonstration.

1. Open the **Demo** project if it is not currently open.
2. Your SAS administrator is typically responsible for setting up libraries for you to access on the SAS server. However, if you want to define a library within your project to SAS or DBMS tables to which you have Read access, begin by selecting **Tools ⇒ Assign Project Library**.
3. In step 1 of the Assign Project Library wizard, type a name in the **Name** box. The library name follows the same naming rules as a data set or variable name, but you are limited to 8 characters or less. Select the server on which the course data resides and click **Next**.
4. In step 2, provide the path to a location where you have stored data. The path must be relative to the location of SAS. Click **Next**.
5. In step 3, type **access** in the **Name** box and **readonly** in the **Value** box. This ensures that even if you are granted Write access to the data at the operating system or database level, SAS will not enable you to make changes to the data sources in the library. Click **Next**.
6. In step 4, verify the settings and click **Test Library**. You should see **OK** appear. Click **Finish** to define the library in your project.
7. To access the data sources in the library, select **View ⇒ Server List**. Expand **Servers ⇒ your server name ⇒ your library name**. Double-click a SAS data set to add it to the project. **Note:** You might need to refresh the server view to see the current contents of the library. This can be done by right-clicking on the server name and clicking **Refresh**.

To remove the shortcut to the data file in the project, right-click on the data icon and select **Delete**. Deleting a table from a project does not delete the data set from the server; it only removes the reference to the table from the project.
Lesson 3   Working with Tasks
In this demonstration, you use the characterize data wizard to create summary reports and graphs of the Customers data.

1. Open the Demo project.

2. Highlight the Customers data icon in the project tree.

3. Select Tasks ⇒ Describe ⇒ Characterize Data.

4. In Step 1, verify that the data source is the Customers data. Click Next.

5. In step 2, you can customize the report options. To change the name of the data set that includes frequency counts for any character columns, click Browse in the Frequency Data pane.

6. Type CustomerCounts in the File name box, click Save, and then click Next.

7. In step 3, limit the number of unique categorical values to be reported per variable by typing 15.

8. Click Finish to run the task and view the results. To observe the status of the task as it runs, click Details in the lower-left corner of SAS Enterprise Guide. The Task Status window opens, and indicates the processing task, status, and server.

9. The results include frequency counts for character columns, summary statistics for numeric columns, and basic graphs to characterize each.

10. To view the Process Flow, click Process Flow in the toolbar. Notice that the Characterize Data task is linked to the customers data set. Return to the task results by double-clicking the Characterize Data
icon in either the Project Tree or Process Flow.

11. To view the task code, click the **Code** tab. The SAS code can be saved and edited to customize the task results or to use features of SAS that are not available in the SAS Enterprise Guide point-and-click environment.

12. To view the log, click the **Log** tab. The Log window displays messages from SAS for each task that you execute.

13. To view the created data set that contains the summary of frequency counts, click the **Output Data** tab.

14. The output data can be exported easily to a wide variety of other software formats, including Microsoft Excel. To automatically open the data in Excel, return to the Process Flow, and select **Send To ⇒ Microsoft Excel**. Close Excel and do not save the changes.

Save the **Demo** project.
Orion Star managers want a report that lists frequencies and percentages for the products offered in each product category.

1. With the Demo project open, double-click the Data Imported from products.xlsx icon in the Process Flow to open this data source in the Data Grid. Note: If you do not have this data source in the project, add the products SAS data set from the course data.

2. To open the One-Way Frequencies task, select Describe ⇒ One-Way Frequencies above the data grid.

3. Drag Product_Category from the Variables to Assign list and drop it on the Analysis variables role.

4. Select Statistics in the selection pane. To include only the frequency and percent statistics, select Frequencies and percentages.

5. Select Results in the selection pane. To create a data set including the frequency counts and percentages, select the Create data set with frequencies and percentages check box. Click Browse and type ProductCounts in the File name box. Click Save.

6. Select Titles in the selection pane. To modify the title, first clear the Use default text check box. In the Text box, delete the default title and type Number of Products per Category.

7. To give the One-Way Frequencies task icon a more descriptive name in the project, select Properties from the selection pane and click Edit. Type Products per Category in the Label box and click OK.
8. Click **Run** to generate the report and examine the results. View the report in the **Results** tab. Select the **Output Data** tab to view the data set.

9. To remove the title *The FREQ Procedure* that is added to the output automatically, select **Tools** ⇒ **Options**, and select **Tasks General** from the selection pane. Clear the **Include SAS procedure titles in results** check box. You can see here that there is also an option to change or delete the default footnote for all tasks. Click **OK** to close the Options window.

10. To rerun the task, click **Refresh** in the **Results** tab.

Save the **Demo** project.
In this demonstration, you modify the properties of a task to produce HTML, PDF, RTF and text output.

1. In the Demo project, double-click the Products per Category icon in the Project Tree or Project Flow to view the Results tab. Click Modify Task.

2. Select Properties in the selection pane, and then click Edit.

3. Select Results in the selection pane. Select Customize result formats, styles, and behavior and select HTML, PDF, RTF, and Text to view all output possibilities. Change the drop-down menu next to HTML to BarrettsBlue, and then click OK.

4. Click Run to generate the report in all output formats. Click Yes when you are prompted to replace the results. Click the various Results tabs to view each report.

5. Click the Results - HTML tab and select Export ⇒ Export HTML. This opens a window that enables you to select a location to save the generated HTML report. This is how you can save the report and view it outside your SAS Enterprise Guide project.

Save the Demo project.
In this demonstration, you use the List Data task to create a list of customers that includes the ID, name, and age group. A separate report will be generated for each country.

1. In the **Demo** project, select the **Customers** data set in the Project Tree or Process Flow.

2. Select **View ⇒ Task List**. In the Task List, click **List Data**.

3. Assign **Customer_ID**, **Customer_Name**, and **Customer_Age_Group** to the **List variables** role. The columns placed in this role will be printed in the report in the order in which they are listed. Also assign **Customer_Country** to the **Group analysis by** role. A separate report will be produced for each country. Notice, the data will be sorted in ascending order for the **Customer_Country** variable. This window automatically opens when a variable is assigned to the **Group analysis by** role to assign the sort order.

4. To specify a title for the report, select **Titles** in the selection pane. Clear the **Use default text** check box. In the **Text** box, delete the default title and type **Customers List**.

5. Click **Run** to generate the report.

6. To modify the task to change the column labels and remove the row numbers, click **Modify Task** in the Results tab.

7. To specify a custom label for the **Customer_Name** column, right-click the column name in the Task roles pane. Select **Properties** from the menu. In the Properties window, type **Name** in the **Label** box, and then click **OK**.

8. Repeat step 7 to change the label for **Customer_Age_Group** to **Age Group**.
9. To remove row numbers from the report, select **Options** in the selection pane. Clear the **Print the row number** check box.

10. To change the name of the task, select **Properties** in the selection pane, and then click **Edit**. In the **Label** box, type **Customer List by Country**.

11. Click **Run** to generate the report. Click **Yes** when you are prompted to replace the results.

Save the **Demo** project.
The Marketing department at Orion Star wants to run a special promotion targeted at high-activity Orion Club members who were born in 1970 or later. In this demonstration, you use the Edit and Filter Data window to modify the input data for a task.

1. In the **Demo** project, double-click the **Customers** data set in the Project Tree or Process Flow.

2. In the Data Grid, select **Describe ⊳ List Data**.

3. To include only high-activity customers born in 1970 or later, begin by selecting **Edit**.

4. Select **Customer_Type** from the first drop-down list and **In a list** from the second drop-down list.

5. Next to the third box, click the ellipsis button. Click **Add Values** to see the distinct data values in the **Customer_Type** column. Hover your cursor over each value to see the full text. Hold down the CTRL key and select the two values that indicate high activity. Click **OK**.

6. Verify that the following values were selected, and then click **OK**.
   - Orion Club members high activity
   - Orion Club Gold members high activity

7. To add another filter, click the fourth drop-down box and select **AND**. The AND operator requires that both filter conditions be true for a row to be included in the report.

8. Select **Customer_BirthDate** in the first box and **Greater than or equal to** in the second box.

9. Click the ellipsis button. Notice that the values are SAS dates, which are stored as the number of days since 01JAN1960. The formatted values also appear in this window. To filter based on a specific date, you can use the SAS date constant. Click **Cancel** to return to the third box and type
Lesson 3: Working with Tasks

"01JAN1970"d. SAS converts the date within quotation marks to the SAS date equivalent before filtering the data. Click **OK**. **Note**: You must use the form "ddMOnyyyy"d (for example, "18APR1987"d) to reference a SAS date constant in expressions.

10. On the Data page, assign **Customer_ID**, **Customer_Name**, and **Customer_Type** to the **List variables** role.

11. Select **Options** in the selection pane, and then clear the **Print the row number** check box.

12. Select **Titles** in the selection pane. Delete the default title and type **Orion Star Customers List** on the first line and **High Activity Customers Born in 1970 or Later** on the second line.

13. Rename the task to indicate the filter that was applied. In the selection pane, select **Properties**, and then click **Edit**. Type **High Act/1970+** in the **Label** box. Click **OK**.

14. Click **Run** and examine the final report.

15. To more fully document the project to indicate the filter applied in the task, you can use notes. Highlight the **High Act/1970+** task, click the **New** icon, and select **Note**.

16. The note can include any text to explain or document items within the project. Type **This report includes customers in high activity groups born in 1970 or later.**

17. To rename the Note icon in the project, click the **Properties** button and type **Filter Detail** in the **Label** box. Click **OK**.

Save the **Demo** project.
Lesson 3: Working with Tasks

Creating a Bar Chart

To better understand the demographics of the Orion Star customers, management wants to see a comparison of average customer age by country.

1. In the Demo project, highlight the Customers data set in the Project Tree or Process Flow and select Tasks ⇒ Graph ⇒ Bar Chart Wizard.

2. In step 1, verify that Customers is the active data set. Click Next.

3. In step 2, select the Horizontal bar chart check box. To create a separate bar for each country, select Customer_Country in the Bars drop-down list.

4. To order the bars in descending height or length, click the properties button (a page with a checkmark on it). In the Properties window, select Descending bar height. Click OK.

5. To set the length of the bars based on average age, select Customer_Age from the Bar length drop-down list.

6. Click the statistics button (the button with the sigma sign on it), and change the statistic to Average. Click OK, then click Next.

7. In step 3, make the following changes:
   - Select the 3D chart check box.
   - Change the Color bars by drop-down list to Bar category.
   - Select the Data labels check box and change the drop-down list to Average.
   - Select the Use reference lines check box.
   - Click Next.
8. In step 4, change the title to **Average Customer Age by Country**, and then click **Finish**.

9. View the results.

10. To make additional modifications not allowed in the Bar Chart wizard, open the task in Advanced View. Right-click on the **Bar Chart** icon in the Project Tree or Process Flow and select **Open ⇧ Open in Advanced View**.

11. In Advanced View, you can apply formats to variables to modify their appearance. Right-click **Customer_Age** and select **Properties**.

12. Click **Change** to apply a format. In the Formats window, select **Numeric** from the Categories pane and **w.d** from the Formats pane. Change the overall width to **4** and the decimal places to **1**. Click **OK**, and then click **OK** again.

13. Select **Layout** in the selection pane. Change the shape to **Cylinder**.

14. Select **Horizontal Axis** in the selection pane. Type **Average Customer Age** in the **Label** box and change the font size to **12**.

15. Select **Reference Lines** in the selection pane. Select the **Specify values for lines** check box, type **20**, and then click **Add**. Repeat for **40** and **60**. Change the style to **Dashed** and the color to light gray.

16. Select **Vertical Axis** in the selection pane. Type **Country** in the **Label** box.

17. Select **Properties** in the selection pane and click **Edit**. Name the task **Avg Age/Country**.

18. The default graph format is ActiveX. To be able to interact with the graph after the task runs, it must be in HTML format. In the Results pane, select **Customize result formats, styles, and behavior** and select **HTML**. Click **OK** to close the Properties window.

19. Click **Run** to generate the graph.

Save the **Demo** project.
1. If necessary, reopen the Graph task named **Avg Age/Country**.

2. Select the **Results - HTML** tab. Right-click the graph to access ActiveX functionality that enables further exploration and modification of the graph. In the menu, select **Graph Properties**.

3. In the **Graph** tab, change the style to **Curve** and a new color scheme is applied.

4. Click the **Bar** tab and select **Font**. Increase the data label font size to **10**. Click **OK** twice to return to the graph and apply the changes.

5. Another change that can be made is to switch the chart type. Right-click on the graph and select **Chart Type  Vertical Bar**.

6. A toolbar is also available to resize, rotate, and subset the graph. Right-click the graph and select **Graph Toolbar**. Click the **Subset** tool. Click and drag your cursor across the first three bars. The chart will be redrawn to include only the outlined portion. Click the **Reset** tool to reset the graph.

7. To save the graph, you can either save the image as a .jpg file (saves any interactive changes you made as a static image) or you can export the graph as an HTML file. (Interactivity is preserved but changes that you made interactively are lost.) To export the HTML result, select **Export  Export HTML – Avg Age/Country**. Navigate to the desired location and click **Save**.

Save the **Demo** project.
Lesson 4  Creating Simple Queries
Orion Star would like to analyze Internet sales that occurred since the beginning of 2008. To prepare the data for input to the various analytic tasks, you must generate a new data source from the Orders table and include only Internet orders placed on or after 01JAN2008.

1. Open the Demo project.
2. Select File ⇒ Open ⇒ Data and navigate to the location where you saved the course data. Select the Orders SAS data set and click Open.
3. Above the data grid, click Filter and Sort.
4. In the Variables tab, click the right double arrow button to add all columns. All Internet orders have the Employee_ID column equal to 99999999, so it can be removed from the result. Select Employee_ID in the Selected pane and click the left single arrow button.
5. Click the Filter tab. Define two filters: Order_Type equals 3 and Order_Date greater than or equal to "01Jan2008"d. Note: you must type the SAS date constant exactly as it's shown here.
6. Click the Sort tab. Select Order_Date as the sort variable and change the sort sequence to Descending.
7. Click the Results tab. Click Change and then type Internet_Orders for the data set name.
8. Click OK and verify the results. This data source is a SAS table that can be exported or used as input for other tasks.
9. Save the Demo project.
1. In the **Demo** project, double-click the **Orders** table. Select **Query Builder** from the Data Grid.
2. The Query Builder enables you to specify the name and storage location of the SAS table that you create. Type **Internet 2008+ Orders Query** in the **Query name** box. Click **Change** next to the **Output name** box. Type **Internet2008** in the **File name** box and click **Save**. **Note:** The table will be saved to the default SAS library. However, a different library can be selected if available.
3. To add all columns to the query, select **t1 (orders)** and drag and drop it in the **Select Data** tab. **t1**, an alias for the table name, is automatically appended to each column from the input table. Remove the **Employee_ID** column by highlighting it in the **Select Data** tab and clicking the **Delete** button.
4. Column properties can also be viewed or modified in the **Select Data** tab. Highlight **Order_Date** and click the **Properties** button to open the Properties window.
5. To apply a format to this column, click **Change**. In the Formats window, select **Date** from the Categories pane and **MMDDYYw.d** from the Formats pane. Change the overall width to **10** and click **OK**. Click **OK** to return to the Query Builder.
6. To include only Internet orders placed on or after 01JAN2008, click the **Filter Data** tab. Drag and drop **Order_Type** into the **Filter Data** tab to start the Basic Filter wizard.
7. In step 1, change the operator to **Equal to** and type **3** in the **Value** box. Click **Next** to verify the filter and select **Finish**.
8. Drag **Order_Date** onto the **Filter Data** tab. In step 1, change the operator to **Greater than or equal to** and type "01JAN2008"d in the Value box. Click **Next** to verify the filter. Notice that by default, AND is used to connect the two conditions. Click **Finish**.
9. Click the **Sort Data** tab. Drag and drop **Order_Date** into the **Sort Data** tab and change the sort direction to **Descending**.
10. Click **Run** to execute the query and view the resulting SAS table. Save the **Demo** project.
Lesson 4: Creating Simple Queries

Demonstration

Creating a Column with an Expression

This demonstration uses the Computed Column wizard to define new columns based on advanced expressions.

Orion Star would like to analyze shipment methods by determining how many days passed between each order date and delivery date. The company also wants to calculate the total amount invoiced to the customer, which is the sum of the total retail price and shipping charges. Use the Query Builder to create a table named Shipping with the new computed columns.

1. Open the Demo project if necessary. In the Project Tree or Process Flow, right-click Orders and select Query Builder from the pop-up menu. Note: If you do not have the Demo project saved, you can create a new project and add the Orders table.
2. Type Shipping Detail Query in the Query name box. Click Change and type Shipping in the File name box. Click Save.
3. Verify that the Select Data tab is active. Add the following columns from the orders table: Order_ID, Order_Date, Delivery_Date, Product_ID, Total_Retail_Price, Shipping, and Profit.
4. To add a computed column to the query, click Computed Columns. In the Computed Columns window, click New.
5. In step 1, select Advanced expression, and then click Next.
6. In step 2, expand Selected Columns. Double-click Delivery_Date to add the column to the expression. Select or type a minus sign, and then double-click Order_Date to complete the expression. Click Next.
7. In step 3, type Days_to_Deliver in the Column Name and Identifier boxes. Type Days to Deliver in the Label box.
8. Click Next.
9. In step 4, review the summary of the new column's properties and click Finish.
10. Open the New Computed Column wizard again to create the Invoice_Amt column.
11. In step 1, select Advanced expression, and then click Next.
12. In step 2, expand the Functions folder and find the SUM function. Double-click SUM to add it to the expression. Notice that the syntax for the SUM function is to the right of the list of functions.

13. Expand Selected Columns. Double-click Total_Retail_Price, and then type or click the comma. Double-click Shipping to complete the expression as follows: SUM(Total_Retail_Price, Shipping). Click Next.

14. In step 3, type Invoice_Amt in the Identifier and Column Name boxes, and then type Invoice Amount in the Label box. To display the data values as currency, click Change. In the Format window, select Currency from the Categories pane and DOLLARw.d in the Formats pane. Change the overall width to 8 and the decimal places to 2. Click OK. Click Next.

15. Verify the summary of the properties and click Finish. Both new columns are added to the selection pane and the Select Data tab.

16. To emphasize the orders with the longest delivery time, sort the table in descending sequence by Days_to_Deliver. Select the Sort Data tab, and drag and drop the Days_to_Deliver column into the tab area. Change the sort direction to Descending.

17. Run the query and examine the results.

Save the Demo project.
Orion Star would like to offer a sales promotion that highlights the top products purchased. The company wants a list of all products with a total profit exceeding $500. Use the Query Builder to group, summarize, and filter the Orders data set.

1. In the Demo project, right-click the Orders table in the Project Tree or Process Flow and select Query Builder.
2. Name the query Top Products Query and name the output table TopProducts.
3. Double-click Product_ID and Profit in the selection pane to add both columns to the Select Data tab.
4. In the Select Data tab, click in the Summary column for the Profit column. Select the SUM statistic from the drop-down list. Note: Choosing a summary statistic causes the Automatically select groups check box to be selected.
5. Click the Filter Data tab. Drag _Calculation to the Filter the summarized data pane.
6. In the New Filter wizard, verify that the alias is SUM_of_Profit. Click Greater than in the Operator box. Type 500 in the Value box and click Finish.
7. Click the Sort Data tab. Drag and drop _Calculation into the tab area and change the sort direction to Descending.
8. Click Run and verify the results. Save the Demo project.
In a previous query, products with total profits exceeding $500 were identified. Orion Star Analysts need more details about these top products, including the product category, product, supplier, and country name. To include the necessary columns, use the Query Builder to join the Topproducts data set, the Products data set, and the Country_Lookup Excel spreadsheet.

1. In the Demo project, add the Topproducts SAS data set if you did not create it in an earlier demonstration.
2. Add the Products SAS data set to the project.
3. Add the Country_Lookup.xlsx file to the project. Name the imported table Country_Lookup and select the First row of range contains field names check box. Do not make any changes to the field attributes. Import the data.
4. Right-click Topproducts in the Project Tree or Process Flow and select Query Builder.
5. Name the query Top Products Info Query and the output table Topproductsinfo.
6. Click Add Tables. Verify that the Project icon is selected in the Open Data window. Hold down the CTRL key and select the Products and Country_Lookup tables. Click Open. Note: To view the full table names, you can select and change the view to Details.
7. A message appears and indicates that SAS Enterprise Guide was unable to find matching columns to use for joining all three tables. Click OK.
8. The Tables and Joins window automatically opens. To join the Products and Country_Lookup tables, first select Supplier_Country in the Products table. Select Supplier_Country a second time and drag it to connect it to Country_Key in the Country_Lookup table. Note: You can also right-click Supplier_Country and select Join with t3 Country_Key.
9. The Join Properties dialog box automatically opens. Verify that the join type is Matching rows only given a condition (Inner Join) and that the condition is t2.Supplier_Country = t3.Country_Key. Click OK. Then click Close to return to the Select Data tab.
10. Select and drag the following columns to add them to the Select Data tab: Product_ID, SUM_of_Profit, Product_Category, Product_Name, Supplier_Name, and Country_Name.
11. Move Sum_of_Profit to the bottom of the list of columns.
12. Click **Run**. Verify the results. Save the **Demo** project.
Lesson 5   Creating Summarized Output
Demonstration

Summarizing Data
In this demonstration you export the results of the **Profit by Product Summary** task to create two external files.

1. In the **Demo** project, open the **Profit by Product Summary** task results.
2. First, export the output data to Excel. Click the **Output Data** tab.
3. Click **Export ⇒ Export as a Step In Project**.
4. In step 1 of the Export wizard, verify that **Summary Statistics for <library>.ORION_PROFIT** is highlighted. Click **Next**.
5. In step 2, select **Microsoft Excel 97-2003 Workbooks (*.xls)** as the output file type. Click **Next**.
6. In step 3, select the **Use labels for column names** check box. Click **Next**.
7. In step 4, change the name of the output file. Click **Browse**. Navigate to any location where you have write-access. In the **File Name** box, type **Profit_Summary**. Click **Save**. **Note**: If you clear the **Overwrite existing output** check box and a file with the same name already exists, then a new filename is created by appending the current date and time to the existing filename.
8. Click **Next**. Review the export settings, and then click **Finish**. The **Profit_Summary.xls** file is exported and an Export File task is added to the project.
9. Export the report. Click the **Report** tab, then click **Export ⇒ Export as a Step In Project**.
10. Click **Next** to go to Step 2.
11. Select **HTML documents**. Click **Next**.
12. In step 3, change the name of the output HTML file. Click **Browse**. Navigate to any location where you have write-access. In the **File Name** box, type **Profit_Summary**. Click **Save**.
13. In Step 4, verify your selections and click **Finish**.
14. Click **Modify Task** to make a change to the task. In Step 3, select the **Sum** statistic. Click **Finish** and run the task. This updates the output of the task but not exported files.
15. Open the Process Flow and select the **Profit by Product Summary task** icon. Click the **Run** menu and select **Run Branch**. The exported files are updated.

Click the **Save Project** tool.
1. In the Demo project, select Tasks ➔ Data ➔ Create Format from the menu bar.
2. Create a numeric format named Order_Type_Detail. Type Order_Type_Detail in the Format name box. In the Location to store format pane, select a permanent library that you have access to (or select Work if you don't have access to a permanent library) in the Library box. Because this format will be applied to numeric values, make sure the format type is Numeric.
3. Select Define formats in the selection pane. Click New Label and type Retail Sales in the Label box. Click New Range and type 1 in the Values box.
4. For the next order type, click New Label, and type Catalog Sales. Click New Range and type 2 in the Values box.
5. For the final order type, click New Label, and type Internet Sales. Click New Range and type 3 in the Values box.
6. Click Run. Notice the addition of the Create Format task to the Project Tree and Process Flow windows. No output is generated. Check the log to make sure the format was created.
7. Add the Country_region_lookup data set to the Demo project.
8. Select Tasks ➔ Data ➔ Create Format from Data Set.
9. Name the format Region.
10. For Discrete value, select Country_code. for Label, select Region.
11. Change the maximum label length to 20 so that the length is long enough for the longest label.
12. Click Run. Check the log to make sure that the format was created. The format has a dollar sign in front of the name because it is a character format.
13. In the Project Tree or Process Flow window, double-click the Orion_Profit table to open it in the Data Grid. Select Describe ➔ Summary Statistics.
14. On the Data page, assign Profit to the Analysis Variables role. Assign Customer_Country to the Classification Variables role. Assign Order_Type to the Group by role.
15. In the Task roles pane, right-click the Customer_Country variable and select Properties.
16. In the Properties dialog box, click Change and then select the User Defined category in the Formats dialog box. Highlight the $REGION. format and click OK twice to return to the Task dialog box. 
   Note: Character formats are automatically renamed to begin with a $.
Lesson 5: Creating Summarized Output

17. To order the results in alphabetic order by the formatted values, select Customer.Country in the Task roles pane. On the right, change the Sort by drop-down list to Formatted values.
18. In the Task roles pane, right-click the Order_Type variable and select Properties.
19. In the Properties dialog box, click Change and then select the User Defined category in the Formats dialog box. Highlight the Order_Type_Detail format and click OK twice to return to the Task dialog box.
20. On the Basic Statistics page, select only the Mean and Sum. Change the number of decimal places to 2.
22. On the Properties page, click Edit and type Profit by Region Summary in the Label box. Click OK.
23. Click Run. View the report. You have used a format to group and summarize data. Save the Demo project.
Lesson 5: Creating Summarized Output

Creating a Tabular Report

In this demonstration, you use the Summary Tables Wizard to generate descriptive statistics and display them in a tabular report.

1. In the Demo project, double-click the Orion_Profit table to open it in the Data Grid.
2. Select Describe ⇒ Summary Tables Wizard from the Data Grid.
3. In step 1, verify that the active data source is the Orion_Profit table. Click Next.
4. In step 2, assign analysis variables. To calculate the sum of profit, click Add, then select Profit.
5. To apply a format so that the values in the table appear as currency values, click Browse. Select Currency from the Categories pane and DOLLARw.d from the Formats pane. Change the overall width to 8 and leave the number of decimal places as 0. Click OK, then click Next.
6. In step 3, assign classification variables to define the rows and columns of the table. For Columns, click Add and then select Customer_Age_Group. For Rows, click Add and select Product_Category.
7. Click Finish. View the report. We need to make a few changes in the Wizard. Click Modify Task.
8. To delete the headers, click Next to advance to step 2. Change the values for Analysis variable labels and Statistics labels to hidden.
9. Click Next. To group Product_Category by Product_Line, click Add and select Product_Line in the Rows box. Click the Up arrow to move Product_Line to the top of the list.
10. To delete the label for Product_Category and the extra blank space that is included in the first row of the table, click More Options. Select Hide the row headers and click OK. Then, click Next.
11. To add subtotals for each value of Product_Line, change the value in the Rows box to Totals at each level.
12. Click Finish. When you are prompted to replace the results, click Yes.
13. View the report.
Save the Demo project.
In this demonstration, you make modifications to the summary table in Advanced View.

1. In the Demo project, right-click the Summary Tables Wizard icon in the Project Tree or Process Flow window and select Open ⇒ Open in Advanced View.
2. In the selection pane, select Summary Tables. To change the column heading for Customer_Age_Group, right-click Customer_Age_Group in the Preview area and select Heading Properties.
3. In the Heading Properties dialog box, type Profit by Customer Age Group in the Label box. Click OK. Note: If you delete a label entirely, the box will also be removed from the final report.
4. Change the column heading for the Product_Line subtotals by right-clicking the Total label and selecting Heading Properties.
5. Type Product Line Subtotal in the Label box. Click OK.
6. To highlight the subtotals with a different color background and font, right-click Total (the subtotals for Product_Line) and select Data Value Properties.
7. In the Data Value Properties window, click the Font tab. Select the Bold Italic font style and light yellow for the background color. Click OK.
8. To specify a label for missing values, right-click anywhere on the table and select Table Properties.
9. In the Table Properties window, click the General tab. Delete the default label in the Label for missing values box and type **. Click OK.
10. Click Run to generate the final report. Click Yes when you are prompted to replace the results.
11. Rename the task Profit by Customer Age Group.

Save the Demo project.
Lesson 6  Using Prompts in Tasks and Queries
This demonstration is not available for you to run in SAS Enterprise Guide. You will use prompts in a demonstration later in this lesson.
In this demonstration you create a variable prompt and use it in a task.

1. In the **Demo** project, add the **Orion_Profit** data set.
2. Click the **Prompt Manager** button in the Resources pane. Click **Add**. Note: If you do not see the Resources pane, select **View ➤ Prompt Manager**.
3. On the **General** tab, type **Profit_Categories** in the **Name** box and type **Select a Variable to Segment the Pie Chart:** in the **Displayed text** box. Select the **Requires a non-blank value** check box.
4. On the **Prompt Type and Values** tab, change the prompt type to **Variable** so that the prompt will be accessible in tasks. To populate the prompt list with variables from the **Orion_Profit** data set, click **Load Values**.
5. In the Open file window, select **Project**, and then double-click **Orion_Profit**. All character variables from the **Orion_Profit** data set are entered into the list. Because **Customer_Name** is not an appropriate variable to use in the Bar Chart task, remove it from the list by highlighting **Customer_Name** and clicking the **Delete** button.
6. To assign a default value, select the **Default value** check box and double-click **Product_Category**. Click **OK** to close the Add New Prompt window.
7. In the Data Grid, select **Graph ➤ Pie Chart Wizard**.
8. Click **Next** to advance to step 2. Select the prompt **Profit_Categories** in the **Slice** drop-down list and **Profit** in the **Slice size** drop-down list. Click **Next**.
9. In step 3, select **3D chart** and select the **Percentage** check box. Change the value to **Inside**. Click **Next**.
10. In step 4, delete the default title and type **Profit by &Profit_Categories**.
11. Click **Finish**. In the prompt window, select **Customer_County**, then click **Run**. Examine the results. Note: A warning symbol might appear on the task icon. This symbol indicates a warning in the log regarding overlapping text in the graph.
12. On the **Results** tab, click **Refresh**. In the prompt window, select **Product_Category**, and then click **Run**.
Save the Demo project.
Lesson 6: Using Prompts in Tasks and Queries

1. In the Demo project, right-click Orion_Profit in the Project Tree or Process Flow, and select Query Builder.
2. Type Choose a Supplier Query in the Query name box. Click Change and type SupplierOrders in the File name box. Click Save.
3. In the Select Data tab, add Product_ID, Product_Name, Order_Date, Quantity, and Profit.
4. To build the prompt that enables the selection of a single supplier, click Prompt Manager, then click Add.
5. In the General tab, type ChooseSupplier in the Name box and type Select a Supplier: in the Displayed text box. Select the Requires a non-blank value check-box.
6. In the Prompt Type and Values tab, verify that the prompt type is Text. Change the method for populating the prompt to User selects values from a static list. To populate the list with supplier names from the Orion_Profit data set, click Get Values.
7. To define the data source, click Browse, and then click Project. Double-click Orion_Profit.
8. In the Column drop-down list, select Supplier_Name and then click Get values.
9. Click the double arrow to move all the values to the prompt list, and then click OK.
10. We’ve defined the prompt and it’s listed in the Prompt Manager. Let’s close this window and get back to our query. Click OK, then click Close to return to the Query Builder.
11. To use the prompt in a filter, select the Filter Data tab. Drag and drop Supplier_Name into the Filter Data tab. In the New Filter wizard, verify that the operator is Equal to. Select the down arrow next to the Value box and click the Prompts tab. Select &ChooseSupplier and click OK. Click Finish.
12. Click the Sort Data tab. Drag Profit to the tab and then select Descending.
13. Change the query options to create a report instead of output data. Click Options. Override the default output type and select Report.
14. In the Query Options window, click Titles. Override the default settings and type &ChooseSupplier Orders. Click OK.
15. Click Run. In the Prompt window, select Carolina Sports, and then click Run. Verify that 11 rows are returned.
16. Export the report as a step in the project and save the report as a PDF file that can be emailed to suppliers.
Save the **Demo** project.
Lesson 7    Customizing and Organizing Project Results
Orion Star has a default color scheme that should be applied to all reports in presentations inside and outside the company. Use the Style Editor to create a custom style that coordinates with the company logo.

1. To create a customized style sheet, select Tools ⇒ Style Manager.
2. Notice that the Analysis style is bold, which indicates that it is the current default style. To create a new style for Orion Star, begin by selecting sasweb, and then click Create a Copy.
3. Type OrionStyle in the File name box and select Save.
4. A personal style named OrionStyle is added to the list of available styles. To edit the style, highlight OrionStyle and click Edit.
5. The Style Editor window opens. You click in the preview area to change elements of the style.
6. Click one of the blue Row header boxes. Click the background color drop-down arrow and click Custom Colors. Type the following values for Red, Green, and Blue: 56, 114, 172. Click Add to Custom Colors. Select the color box and click OK.
7. Click one of the blue Column header boxes. Click the background color drop-down arrow and then select the custom color box you just defined.
8. Click SAS System Footnote in the preview pane. Change the text color to the new custom color.
9. Click SAS System Title in the preview pane. Change the text color to the new custom color.
10. Click SAS Procedure Title in the preview pane. Change the text color to Black.
11. Click Graph Results in the preview pane. Change the text color to Black.
12. Click one of the data cells in the preview table. Click the background color drop-down arrow and click Custom Colors. Type the following values for Red, Green, and Blue: 255, 255, 204. Click Add to Custom Colors. Select the color box and click OK.
13. To change the background color of the table, select one of the data cells in the preview.
14. To make the background a very pale yellow, select the arrow next to Color in the Background color pane. Click Custom Colors and choose a pale yellow. Click Add to Custom Colors and then click OK.
15. Click OK to close the Style Editor and save the changes to the new style.
16. The new **OrionStyle** is automatically the default style for all tasks you run. Click **OK** to close the Style Manager.

17. To update the results with the new style applied, open a task that creates a report and click **Refresh**.

**Note:** When you create and apply a custom style, a warning similar to the following might be generated in task logs:

```
WARNING: Style new_style_name not found; Default style will be used instead.
```

The warning occurs because the SAS server is not able to find the style you are using, but SAS Enterprise Guide still uses the style to display the results. To circumvent the warning, you can name your custom style the same as an existing SAS style.
Combining Results in a Single Report

In this demonstration, you create a single report from multiple results.

1. In the Demo project, select File  New  Report.
2. Add the bar chart Profit by Customer Age Group to the report by dragging it to the left top grid. Next to that, add the summary table Profit by Product Category.
3. Below those two results, add Profit by Customer Country and Type. Drag the right border of the report to the right so that the results span two columns.
4. Click OK and view the report.
5. Click Header and Footer. In the Header tab, click Browse, and select the Orion banner image.
6. Add a line below the banner and change the style to Double.
7. Click the Titles and Footnotes tab. Clear the checkboxes next to all footnotes except the one for the summary table report at the bottom. Click OK.
8. Click Page View and notice that there is not sufficient room to display the graph and report side by side. Click Normal View. Click in the graph and then resize it by dragging a corner of the blue box. Click Page View to see if the graph is now beside the table.
9. In Normal View, remove the page breaks that cause the last report to display on a second page. Click the arrow next to Modify Report, and then select Remove All Page Breaks.
10. Click Page View to confirm the final appearance of the report.
11. Right-click the Report icon in the Project Tree and select Rename. Change the name to Profit Report. Press Enter.
12. To export the results, select Export  Export Report As A Step In Project.
13. In step 1, verify that Profit Report is highlighted and click Next.
14. In step 2, select HTML Documents (*.html) and click Next.
15. In step 3, navigate to a location where you can save a file and name the file ProfitReport.html. Click Next.
16. In step 4, view the summary and click Finish to complete the export. The exported HTML file can then be published to the intranet or distributed to others to view in a browser. Save the Demo project.
In this demonstration, you use the process flow to update results.

1. Open the Demo project. Notice that the entire project is contained in one process flow.
2. To create a new process flow, select File ⇒ New ⇒ Process Flow. Click the Properties button and type Weekly Orion Reports in the Label box. Click OK.
3. Double-click Process Flow in the Project Tree to return to the original process flow.
4. In the Process Flow, use your cursor to make a box around the 3 tasks that use the Orion_Profit data. You don't need the Choose a Supplier Query. Right-click one of the highlighted items and select Move To ⇒ Weekly Orion Reports.
5. The Create Format from Data Set task generates a format used in the Summary Statistics task you just moved. Right-click the Create Format from Data Set task and select Move to ⇒ Weekly Orion Reports.
6. Select Weekly Orion Reports in the Project Tree to view the new process flow. To ensure that the Format task runs before any of the other tasks, right-click the Create Format from Data Set task and select Link to. In the Link To window, select Orion_Profit. Click OK.
Select Run ⇒ Weekly Orion Reports. While the results are updating, you can watch the process flow to see what tasks are running.